Cannot prepare pod for PeerReview3

after changing the Podfile, i ran ‘Pod Install’ but getting error msg

=[ Error message , 1st part ] ===========

ArgumentError - Illformed requirement "-> 0.1"

=[ Error message , last part ] ===========

[!] Oh no, an error occurred.

Search for existing GitHub issues similar to yours:

If none exists, create a ticket, with the template displayed above, on:

Be sure to first read the contributing guide for details on how to properly submit a ticket:

Don’t forget to anonymize any private data!

=[ Podfile content ]==========

Uncomment this line to define a global platform for your project

platform :ios, ‘8.0’

Uncomment this line if you’re using Swift

use_frameworks!

target ‘PeerReview03’ do

pod ‘CurrencyRequest’ , ‘-> 0.1’

end

I think you need a ~ (tilda) instead of a - for the -> 0.1 part.

So it should look like ~> 0.1 (or tilda greater than sign) vs. -> 0.1 (minus sign greater than sign)…

2 Likes

thx that did the job

1 Like