Pod install Error in PeerReview03

I don’t have GVIM so I used vim instead and typed the exact same thing as the lecture:

Uncomment this line to define a global platform for your project

platform :ios, ‘8.0’

Uncomment this line if you’re using Swift

use_frameworks!

target ‘PeerReview03’ do

pod ‘CurrencyRequest’, ‘-> 0.1’

end

When I typed “pod install” here is what happened

Tiancongs-MacBook-Pro:PeerReview03 tiancongzhou$ pod install
Updating local specs repositories

CocoaPods 1.0.0.beta.2 is available.
To update use: gem install cocoapods --pre
[!] This is a test version we’d love you to try.

For more information see http://blog.cocoapods.org
and the CHANGELOG for this version http://git.io/BaH8pQ.

Analyzing dependencies

――― MARKDOWN TEMPLATE ―――――――――――――――――――――――――――――――――――――――――――――――――――――――――――

Command

/usr/bin/pod install

Report

  • What did you do?

  • What did you expect to happen?

  • What happened instead?

Stack

   CocoaPods : 0.39.0
        Ruby : ruby 2.0.0p481 (2014-05-08 revision 45883) [universal.x86_64-darwin14]
    RubyGems : 2.0.14
        Host : Mac OS X 10.10.5 (14F1509)
       Xcode : 7.2 (7C68)
         Git : git version 2.7.0
Ruby lib dir : /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib
Repositories : master - https://github.com/CocoaPods/Specs.git @ deaf4eb7e33366abd14b9ac9c9dfc096c6305012

Plugins

cocoapods-plugins : 0.4.2
cocoapods-search  : 0.1.0
cocoapods-stats   : 0.6.2
cocoapods-trunk   : 0.6.4
cocoapods-try     : 0.5.1

Podfile

# Uncomment this line to define a global platform for your project
# platform :ios, '8.0'
# Uncomment this line if you're using Swift
# use_frameworks!

target 'PeerReview03' do

pod 'CurrencyRequest', '-> 0.1'

end

Error

ArgumentError - Illformed requirement `"-> 0.1"`
/Library/Ruby/Gems/2.0.0/gems/cocoapods-core-0.39.0/lib/cocoapods-core/requirement.rb:63:in `parse'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-core-0.39.0/lib/cocoapods-core/requirement.rb:88:in `block in initialize'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-core-0.39.0/lib/cocoapods-core/requirement.rb:88:in `map!'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-core-0.39.0/lib/cocoapods-core/requirement.rb:88:in `initialize'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-core-0.39.0/lib/cocoapods-core/requirement.rb:34:in `new'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-core-0.39.0/lib/cocoapods-core/requirement.rb:34:in `create'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-core-0.39.0/lib/cocoapods-core/dependency.rb:92:in `initialize'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-core-0.39.0/lib/cocoapods-core/podfile/target_definition.rb:650:in `new'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-core-0.39.0/lib/cocoapods-core/podfile/target_definition.rb:650:in `block in pod_dependencies'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-core-0.39.0/lib/cocoapods-core/podfile/target_definition.rb:646:in `map'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-core-0.39.0/lib/cocoapods-core/podfile/target_definition.rb:646:in `pod_dependencies'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-core-0.39.0/lib/cocoapods-core/podfile/target_definition.rb:87:in `non_inherited_dependencies'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-core-0.39.0/lib/cocoapods-core/podfile/target_definition.rb:79:in `dependencies'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-0.39.0/lib/cocoapods/installer/podfile_validator.rb:59:in `block in validate_pod_directives'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-0.39.0/lib/cocoapods/installer/podfile_validator.rb:58:in `each'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-0.39.0/lib/cocoapods/installer/podfile_validator.rb:58:in `flat_map'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-0.39.0/lib/cocoapods/installer/podfile_validator.rb:58:in `validate_pod_directives'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-0.39.0/lib/cocoapods/installer/podfile_validator.rb:29:in `validate'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-0.39.0/lib/cocoapods/installer/analyzer.rb:155:in `validate_podfile!'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-0.39.0/lib/cocoapods/installer/analyzer.rb:57:in `analyze'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-0.39.0/lib/cocoapods/installer.rb:213:in `analyze'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-0.39.0/lib/cocoapods/installer.rb:136:in `block in resolve_dependencies'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-0.39.0/lib/cocoapods/user_interface.rb:59:in `section'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-0.39.0/lib/cocoapods/installer.rb:135:in `resolve_dependencies'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-0.39.0/lib/cocoapods/installer.rb:105:in `install!'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-0.39.0/lib/cocoapods/command/project.rb:71:in `run_install_with_update'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-0.39.0/lib/cocoapods/command/project.rb:101:in `run'
/Library/Ruby/Gems/2.0.0/gems/claide-0.9.1/lib/claide/command.rb:312:in `run'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-0.39.0/lib/cocoapods/command.rb:47:in `run'
/Library/Ruby/Gems/2.0.0/gems/cocoapods-0.39.0/bin/pod:44:in `<top (required)>'
/usr/bin/pod:23:in `load'
/usr/bin/pod:23:in `<main>'

――― TEMPLATE END ――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――――

[!] Oh no, an error occurred.


Tiancongs-MacBook-Pro:PeerReview03 tiancongzhou$

This is the line you typed into your Podfile:

pod ‘CurrencyRequest’, ‘-> 0.1’

Go back to the instructions, read them very carefully, and see if you can find the error you made.

I checked again and did not find anything wrong with what I typed.
Still comes out the same thing.

Chad, the ‘hyphen’ and ‘tilde’ characters are not the same character. If the names of these characters are unfamiliar to you, perhaps that is the source of your confusion. If you do know the difference between these two characters, and you mistakenly think you typed a ‘tilde’, you didn’t. You typed a ‘hyphen’. Sometimes it’s difficult to see the difference in pasted text without corrective lenses, but that should not be the case in your command-line environment, since you can increase the default font size using the Preferences window for the Terminal application. In fact, you pasted a screen shot of your error messages in Xcode, and the font size is certainly large enough to read, don’t you think? You have made a typing error, and there is no profit in continuing to assume you did not.

Oh I got it working now.
Thank you so much for your patience.

Good work, Chad. It’s actually not the first time anyone has encountered exactly the same problem:

The podfiles aspect of this coursework is very much a cookbook approach at this point. I certainly don’t understand the code that Sam Kaufman put in the DGCurrencyRequest class, but I think it’s a pretty cool way to incorporate interesting capabilities into our very rudimentary software projects. Eventually, I guess, we discover that there’s a lot of open source code out there. Watch out for the licenses in deciding whether or not to put your project in the AppStore and charge anything for it.

Hi.
HELP.
I did use a Tilda.

I tried to open my text editor from Terminal – couldn’t do it, so I edited and saved the file AS TEXT, but used the gui.
Fine.
Then this is what I got when I entered
pod install

and then… nothing no deb$
and waiting and waiting…

Ah,
A bit later

all’s good.
Learned there are different quote types.
okay

imagine I should not install CocoaPods 1.2.0

moving on…

cheers,
deb

Hello I am having the same problem as well.

I am not sure what I am doing wrong.

Did you type pod init before changing your podfile?

Dyne2Meter, I’ve read several of your replies and I have to say I very much do not appreciate your tone. You are rude and condescending to people who are trying to learn. I have news for you: just because you know some things doesn’t mean you’re so much smarter or better than anyone else. You are the quintessential hateful nerd, and it’s not helpful in this forum.