Week1_Module3 "no process id or name specified" error in terminal

When I was doing command line project, while I tried to run the programme in terminal at the very last step to run the specific sample by typing the name of the file, which is “Sample”, there comes all these error message:
[invalid usage]: no process id or name specified
Usage: Sample <pid/partial name> [duration [samplingInterval]] [options…]

Specify the duration in seconds; the default is 10 seconds.
Specify the samplingInterval in milliseconds; the default is 1 millisecond.

options: [-wait] [-mayDie] [-fullPaths] [-e] [-file ]
-wait wait until the process named (usually by partial name) exists, then start sampling
-mayDie reads symbol information right away
-fullPaths show full paths to source files if debug info is available
-e open the output in TextEdit
-f/-file specifies where results should be written

How can I fix it? And what went wrong? Thank you!

I have the same issue.

solved! you have to put ./sample instead of sample.
don’t forget the dot
it seems that sample is a command in terminal (??)

1 Like

I had the same issue! Thanks for clearing it up for me :slight_smile:

I also had the same issue. Thanks a lot!